PPA.Lab - Routing Information Protocol (RIP)

GNS3

1. Topology

2. Configure basic settings

R1

R1#configure terminal
R1(config)#interface s1/0 
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#network 192.168.1.0

R2

R2#configure terminal
R2(config)#interface s1/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fa0/0
R2(config-if)#ip address 172.16.1.2 255.255.0.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 172.16.0.0
R2(config-router)#network 192.168.1.0

3. Cloud (loopback interface)

C:\>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection 7:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::858e:7937:150f:df1e%29
   IPv4 Address. . . . . . . . . . . : 172.16.1.2
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . : 172.16.1.1


C:\>

4. Display Filters on Wireshark

rip

5. Sample .pcap file

6. Routing Information Protocol (RIP)

  • Dynamic routing protocol

  • Uses hop count as a routing metric

  • It is a distance vector routing protocol

  • Has AD value 120

  • Works on the application layer of OSI model

  • Uses port number 520

7. Features of RIP :

  • Updates of the network are exchanged periodically.

  • Updates (routing information) are always broadcast.

  • Full routing tables are sent in updates.

  • Routers always trust on routing information received from neighbor routers. This is also known as Routing on rumours.

Last updated